SOCL.cz
blog nejen o Internetu

MikroTik: IPv6 tunel snadno a rychle

publikováno 4. 4. 2015 v 22:24

Můj domácí poskytovatel Internetu (ISP) se nijak nemá k zavedení nativní IPv6 konektivity pro své zákazníky, proto doma využívám na svém MikroTik routeru statický IPv6 tunel od TunnelBroker.net. Stačila mi k tomu statická veřejná IP adresa a trošku trpělivosti při nastavování.

Pokud chceme využívat tunelu společnosti Hurricane Electric, zřídíme si účet na výše uvedeném odkazu. Můžeme však využít i jiných hráčů na trhu, např. SixXS, principy jsou identické. V našem případě po přihlášení k účtu zvolíme volbu Create Regular Tunnel, kdy jako koncový bod (IPv4 Endpoint) zadáme naši statickou veřejnou IP adresu a vybereme nejbližší tunnel server - tady doporučuji vybrat server v Praze (přeci jen je pravděpodobné, že na něj budeme mít nejnižší odezvu), viz obrázek:

Vytváříme nový IPv6 tunel
Vytváříme nový IPv6 tunel

Po úspěšném vytvoření tunelu si prohlédneme jeho parametry:

Parametry nového tunelu
Parametry nového tunelu

Dostali jsme k dispozici routovatelný prefix 2001:470:6f:6xx::/64 a můžeme nastavit samotný router. Ještě dodám, že je možné nastavit také rDNS neboli reverzní záznamy pro naše IPv6 adresy. K tomuto můžeme zdarma u té samé společnosti využít služby Free DNS. Osobně toto však nenastavuju, protože využívám dočasných náhodných IPv6 adres, takže by jaksi reverzní záznam stejně neměl smysl...

Nastavujeme tunel v RouterOS

V RouterOS musíme mít aktivní balíček pro IPv6! Nejprve nahodíme rozhraní sixbone:

/interface 6to4 add name=sixbone local-address=195.47.235.3 remote-address=216.66.86.122 mtu=1480

Přiřadíme rozhraní sixbone IP adresu:

/ipv6 address add interface=sixbone address=2001:470:6e:6xx::2/64 advertise=no eui-64=no disabled=no

Nastavíme routování:

/ipv6 route add dst-address=2000::/3 gateway=2001:470:6e:6xx::1 scope=30 target-scope=10 distance=1

A ještě nastavení pro naši lokální síť, v mém případě rozhraní local:

/ipv6 address add interface=local address=2001:470:6f:6xx::/64 advertise=yes eui-64=yes disabled=no

V této fázi by už na klientech v naší LAN síti, pokud mají zapnutu podporu IPv6, mohlo vše šlapat. Nezapomeneme ještě v RouterOS nastavit IPv6 firewall (obdobně jako máme nastaven ten pro IPv4), zejména doporučuji neblokovat ICMP provoz. Pokud dopadlo vše v pořádku, měli bychom například zde vidět přiřazenou IPv6 adresu.

 

štítky: 6to4 IPv6 mikrotik tunel
3028x přečteno

Komentáře k článku (0)

Zatím nikdo nic nenapsal, chcete být první?
Vaše jméno/přezdívka: (max 40 znaků)

Web: (nepovinné, max 100 znaků)

Opiště sekvenci znaků:

captcha!

Zde napište komentář: (max 512 znaků)

Copyright © 2015-2017 SOCL.cz, RSS 2.0 RSS kanál blogu
Všechna práva vyhrazena, nebo tak nějak. Kontakt: mujblog(na)socl.cz

WEDOS BANNER